Slowness for users from Switzerland for control.divio.com
Incident Report for Divio Status Page
Resolved
This incident has been resolved.
Posted Jan 15, 2024 - 17:43 UTC
Identified
We got reports that users from Switzerland experience slowness on our control panel at control.divio.com

The issue is presumably related to an issue at Cloudflare and we continue to investigate the issue.
Posted Jan 15, 2024 - 17:12 UTC
This incident affected: Divio Control Panel (control.divio.com).